Excelkurs online

I Excelbloggen tar vi upp funktioner och tips i Excel som är bra att känna till och underlättar vardagen för dig.

Funktionen OM

Formler 2018-02-14

En av de mest användbara formlerna i Excel är OM formeln där man ställer en fråga till en cell och sedan definierar svaret beroende på om det är sant eller falskt.

Börja med att ställ dig i cell B2 och infoga funktionen OM under fliken Formler – välj Logik – välj OM och du får dialogrutan nedan.



Logiskt test – Här ställer vi vår fråga. Frågan kan läsas som att vi först säger ”Om”, som sedan följs av ett påstående, som även kallas för ett villkor, som skall testas. Påståendet innehåller en cellreferens till det värde vi vill undersöka och sedan en jämförande operand, därefter ett värde som vi jämför med. Det sista värdet efter det jämförande operanden kan var en siffra, en ”sträng” eller en cellreferens. Ovan ställer vi frågan om A2 är mindre än 10?

Värde_om_sant – Ifall det logiska testet: är A2 mindre än 10, dvs svaret är Sant, då skall formeln returnera värdet ”Få” som är en sträng.

Värde_om_falskt– Ifall värdet i A2 inte är mindre än 10, dvs svaret är Falskt, då skall formeln returnera värdet ”Många” som är en sträng.

Värdet om sant eller falskt behöver inte var en text eller värde, det kan även vara en beräkning eller anropa en ny funktion. När man har flera funktioner i en så brukar det kallas för nästlad eller kapslad funktion. Det är ganska vanligt att ha flera OM-formler i en och samma funktion, läs mer om nästlad OM-formel här.

När dialogrutan är ifylld enligt ovan får vi en formeln i kolumnen ”Svar” i tabellen nedan. Använd autofyll för att fylla hela kolumnen.

    =OM(A2<10;"Få";"Många")

Formeln ovan kan läsas som: "Om A2 är mindre än 10, returnera texten "Få", annars returnera texten "Många"

Värde

Svar

18

Många

6

7

20

Många

2

3

18

Många

16

Många

7

10

Många

20

Många

13

Många


I bland kan man ha en mer komplexa villkor som man behöver testa och flera olika alternativ svar som skall returneras. Då kan man behöva använda sig av flera OM-formler i en. Det finns förklarat i inlägget om nästlade Om-formler. Det finns även flera andra logiska funktioner som t.ex. OCH(), ELLER() och ICKE() som beskrivs här.



DELA