Excelkurs online

I Excelbloggen tar vi upp funktioner och tips i Excel som är bra att känna till och underlättar vardagen för dig.

Nästlad OM formel

Formler 2018-02-14

I ett tidigare inlägg så gick vi igenom hur en enkel OM formel byggs upp. Det går även att baka in flera om formler i en. En OM-formel testar om ett påstående (villkor) är sant eller falskt och returnerar ett värde beroende på om det är sant eller falskt. Då villkoret är falskt så kan man ställa ett nytt villkor enligt nedan.

1         =OM(A2<7;"Få";

2                           OM(A2<13;"Mellan";

3                                                        "Många"))

I steg 1 har vi en vanlig OM formel som kollar villkoret ifall A2 är mindre än 7? Är det villkoret sant så returneras strängen ”Få”. Därmed avslutas även formeln.

I steg 2 så kommer vi till endast ifall steg 1 har varit falskt. Då förväntar sig formeln en instruktion. Istället för att ange ett värde så lägger vi istället in en ny OM formel som kollar om värdet är under 13. Är det sant så returnerats värdet ”Mellan”.

Kommer vi hela vägen fram till steg 3 så har värdet i A2 varken varit under 7 eller under 13. Då kan vi dra slutsatsen att värdet i A2 måste vara 13 eller mer. Vi anger därför att värdet som skall returneras är ”Många”.

När man gör kapslade Om-formler är det viktigt att tänka på i vilken ordning man ställer sina villkor och läser från vänster till höger.

=OM(A2<7;"Få";OM(A2<13;"Mellan";"Många"))

Värde

Villkor

18

Många

6

7

Mellan

20

Många

2

3

18

Många

16

Många

7

Mellan

10

Mellan

20

Många

13

Många



DELA