Excelkurs online

I Excelbloggen tar vi upp funktioner och tips i Excel som är bra att känna till och underlättar vardagen för dig.

Dynamisk Bild i Excel

Det går att lägga in dynamiska bilder i Excel där ett bildobjekt kan byta innehåll (bild) baserat på värdet i en cell. I följande exempel skall vi lägga in ett bildobjekt som skall visa trafiksignal beroende på vad för värden som finns i en cell.

Se bifogad fil för facit samt tillgång till de bilder som vi skall jobba med i exemplet nedan. Du behöver spara bilderna i en mapp på din dator.

Början med att öppna en tom arbetsbok och ställ dig i en cell t.ex. cell B2.

Skriv in namnet ”Grön” i cell B2:s Namnruta och tryck Enter, enligt bilden nedan. (Där det står ”Grön” i bilden nedan). På så sätt så kan du referera till ”Grön” istället för B2.


Ställ dig i Cell B2 (Grön) och infoga bild med grön trafiksignal. Under fliken Infoga – välj Bilder och välj bilden för grön trafiksignal, klicka Ok.

Snygga till cell B2 så att den täcker den infogade bilden.

Repetera stegen ovanför och lägg in ”Gul” i C3 och ”Röd” i D3.

Ställ dig i cell A2 och skriv in följande formel:

                           =OM(A1=1;"Grön";OM(A1=2;"Gul";OM(A1=3;"Röd")))

Här är det väldigt viktigt att vi använder oss av exakt samma namn som vi tidigare angivit när vi döpte våra celler. Testa även att skriva in värdet 1 , 2 eller tre i cell A1 och kolla att formeln ovan funkar.

Vi skall nu skapa en ny referens som pekar mot värdet i cell A2, som i sin tur ger oss en referens till de tre bilderna vi tidigare definierat.

Under fliken Formler välj Namnhanteraren.

Klicka på Nytt och fyll i enligt dialogrutan nedan.


Ovan har vi använt oss av formeln INDREKT. Den funktionen tar emot en referens som vi skapat via Namnhanteraren, den tar på så sätt endast emot en textsträng och det måste finnas ett motsvarande namn angivet i Namnhanteraren.

Klicka sedan på OK och du skall ha en dialogruta enligt bilden nedan.


Klicka sedan Stäng.

Ställ dig i den cell som du vill ha din dynamiska bild.

Infoga en ny bild, fliken Infoga – välj Bilder. Välj vilken bild som helst och klicka OK.

Se till att bilden du nyss infoga är markerad.

När bilden är markerad så skriver du in i formelfältet ”=Trafiksignal”, se bilden nedan. Tryck sedan Enter.



Ändra värdet i Cell A1 och bilden i F2 kommer att ändras.

I exemplet ovan är även det nya dynamiska bildobjektet döpts till Dyn_Trafiksignal på samma sätt som vi döpte våra tidigare områden. Se bilden ovan.


DELA