Excelkurs online

I Excelbloggen tar vi upp funktioner och tips i Excel som är bra att känna till och underlättar vardagen för dig.

Lägg till och redigera dataetiketter i diagram

I följande exempel skall vi lägga till information till ett vanligt stapeldiagram genom att skapa dataetiketter. Vårt slutresultat skall bli ett stapeldiagram som i bilden nedan som visar försäljning månadsvis över ett år. Vi har även räknat ut månadsresultat jämfört med föregående års resultat. Vi lägger till en pil som indikerar om det är positivt eller negativt och ifall det är negativt så gör vi även texten röd. Vi lägger sedan till den här informationen som dataetiketter.



Vår data ser ut som i bilden nedan där vi har försäljningsdata uppdelat på två år och deras respektive månader. Vi har även räknat ut den procentuella förändringen ifrån föregående år i kolumn D. Du kan ladda ner exempelfil under inläggets rubrik.



Vi skall nu skapa ett stapeldiagram som redovisar 2021 resultat med dataetiketter som vi hämtar ifrån kolumn D. Vi skall även lägga till en uppåt eller nedåt pil till den procentuella utvecklingen samt färga de negativa procenten röda.

Vi måste först infoga våra pilar i var sin cell i dokumentet som vi kan referera till i vår formel. Under fliken Infoga -> Symbol som i bilden nedan.



Du får nu upp dialogrutan Symbol som i bilden nedan. Välj Unikod (hex) längst ner till höger och under Deluppsättning välj Geometriska figurer. Välj sedan en pil och klicka på Infoga en gång och sedan Stäng.



Infoga både uppåt och nedåt pil i var sin cell i ditt dokument som i bilden nedan.

Sedan kan vi skapa våra nya fält med de dataetiketter vi skall använda. Vi kommer att behöva två serier, en med de negativa värdena och den andra med de positiva. I kolumn E har vi skapat de negativa resultaten med med följande formel:

 

2021 Neg =OM(D2<0;SAMMANFOGA($A$17;" ";TEXT(D2;"0,0%"));"")

 

Det är en OM-formel som testar i fall värdet i D2, dvs ”Utvecklingen sedan 2020”, är mindre än noll. Om det är mindre än noll så sammanfogas det värdet med en nedåt pil, A17. Annars så resulterar det med en tom cell ””. Eftersom vi använder en sammanfoga formel så blir resultatet i textformat. Vi skall redovisa i procenttal så vi behöver också bestämma formatet med formeln TEXT(). Vi sätter formatet till ”0,0%”.

I kolumn F samlar vi de med positivt resultat:

 

2021 Pos =OM(D2>0;SAMMANFOGA($B$17;" ";TEXT(D2;"0,0%"));"")