Excelkurs online

I Excelbloggen tar vi upp funktioner och tips i Excel som är bra att känna till och underlättar vardagen för dig.

Arbeta med namngivna områden

I Excel så refererar man ofta till ett område med värden. Istället för att manuellt mata in dessa via tangentbord eller musmarkering så kan man namnge och spara referenser. Det kan bland annat göra det enklare för oss när vi skapar formler.

VI skall göra ett enkelt exmepel på hur man kan jobba med formler genom att räkna ut värden från en tabell och välja element via en dropdownlista. Exempelfil kan laddas ned under rubriken.

Vår data består av en tabell med två kolumner Land och Försäljning enligt bilden nedan. Vi skall börja med att namnge värdena i respektive kolumn. Under Fliken Formler – klicka på Definiera namn så att du får upp dialogrutan enligt nedan.

Namn – Här namnger du området i vårat fall .

Refererar till – Här markerar du de celler som området skall referera till, B2 till B9.

Klicka sedan OK.

För att summera den totala försäljningen så kan man nu istället enkelt ange området Försäljning och det kommer automatiskt fram som förslag när du skriver in formeln.

    =SUMMA(Försäljning)

Motsvarar alltså:

    =SUMMA(B2:B9)

Gör samma sak fast för området A2 till A9 där vi har namnen på länderna. Man kan även under fliken Formler klicka på knappen Namnhanteraren. Då får du upp bilden nedan där du får en överblick över din områden. Du kan härifrån redigera dom och även skapa nya eller ta bort befintliga.

Lägg till en dropdownlista med ländernas namn genom att markera D2. Fliken Data – klicka på Dataverifiering så att du får upp dialogrutan Dataverifiering enligt nedan.

Ställ in enligt bilden ovan. Notera att vi nu inte anger cellreferenser som vår källa utan området Länder, som i sin tur innehåller cellreferenser. Klicka sedan OK.

Ställ upp som i bilden nedan med en SUMMA.OM funktion där villkoret pekar mot värdet i dropdownlistan.

Man kan nu enkelt göra sina beräkningar genom att välja från dropdownlistan och det är väldigt enkelt att se vad som raknas ut.



DELA